Skip to content Skip to sidebar Skip to footer

Cara Konfigurasi Routing OSPF Pada Router Cisco

OSPF (Open Shortest Path First) adalah salah satu dari routing protocol dynamic yang dikembangkan berdasarkan pemilihan jalur terdekat yang akan dilalui sebuah paket data menuju titik tujuannya.

OSPF adalah link-state routing protocol yang menggunakan algoritma SPF (Sort Path First) untuk menghitung jalur terpendek ke setiap titik router lainnya. Routing Update hanya akan dikirim ketika ada link-up maupun link-down.

Pada artikel ini saya hanya focus pada cara konfigurasi routing ospf pada router cisco, yang pada prakteknya saya lakukan di packet tracer.


Cara Konfigurasi Routing OSPF Pada Router Cisco

Sebelumnya silahkan sobat buka packet tracer dan buat topologi seperti ini:

Langkah-langkahnya:

1. Konfigurasi IP Address pada router JAKARTA,

R-JAKARTA(config)#interface gi0/0
R-JAKARTA(config-if)#description to R-MEDAN
R-JAKARTA(config-if)#no shutdown
R-JAKARTA(config-if)#ip address 172.16.0.1 255.255.255.252
R-JAKARTA(config-if)#ex

R-JAKARTA(config)#interface gi1/0
R-JAKARTA(config-if)#description to R-PEKANBARU
R-JAKARTA(config-if)#no shutdown
R-JAKARTA(config-if)#ip address 192.168.0.1 255.255.255.252
R-JAKARTA(config-if)#ex

R-JAKARTA(config)#interface gi2/0
R-JAKARTA(config-if)#description to R-MAKASSAR
R-JAKARTA(config-if)#no shutdown
R-JAKARTA(config-if)#ip address 192.168.1.1 255.255.255.252
R-JAKARTA(config-if)#ex

R-JAKARTA(config)#interface gi3/0
R-JAKARTA(config-if)#description to R-BANDUNG
R-JAKARTA(config-if)#no shutdown
R-JAKARTA(config-if)#ip address 10.10.0.1 255.255.255.252


2. Konfigurasi IP Address pada router MEDAN

R-MEDAN(config)#interface gi0/0
R-MEDAN(config-if)#description to R-JAKARTA
R-MEDAN(config-if)#no shutdown
R-MEDAN(config-if)#ip address 172.16.0.2 255.255.255.252
R-MEDAN(config-if)#ex

R-MEDAN(config)#interface gi1/0
R-MEDAN(config-if)#description to R-ACEH
R-MEDAN(config-if)#no shutdown
R-MEDAN(config-if)#ip address 10.0.0.1 255.255.255.252


3. Konfigurasi IP address pada router ACEH

R-ACEH(config)#interface gi0/0
R-ACEH(config-if)#description to R-MEDAN
R-ACEH(config-if)#no shutdown
R-ACEH(config-if)#ip address 10.0.0.2 255.255.255.252
R-ACEH(config-if)#ex


4. Konfigurasi IP Address pada router BANDUNG

R-BANDUNG(config)#interface gi0/0
R-BANDUNG(config-if)#description to R-JAKARTA
R-BANDUNG(config-if)#no shutdown
R-BANDUNG(config-if)#ip address 10.10.0.2 255.255.255.252


5. Konfigurasi IP Address pada router MAKASSAR

R-MAKASSAR(config)#interface gi0/0
R-MAKASSAR(config-if)#description to R-JAKARTA
R-MAKASSAR(config-if)#no shutdown
R-MAKASSAR(config-if)#ip address 192.168.1.2 255.255.255.252

R-MAKASSAR(config)#interface gi1/0
R-MAKASSAR(config-if)#description to R-BALIKPAPAN
R-MAKASSAR(config-if)#no shutdown
R-MAKASSAR(config-if)#ip address 172.16.1.1 255.255.255.252


6. Konfigurasi IP Address pada router BALIKPAPAN

R-BALIKPAPAN(config)#interface gi0/0
R-BALIKPAPAN(config-if)#description to R-MAKASSAR
R-BALIKPAPAN(config-if)#no shutdown
R-BALIKPAPAN(config-if)#ip address 172.16.1.2 255.255.255.252


7. Konfigurasi IP Addres pada router PEKANBARU

Router(config)#interface gi0/0
Router(config-if)#description to R-JAKARTA
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.0.2 255.255.255.252


Setelah selesai, mari kita lakukan konfigurasi routing OSPF pada masing-masing router,

Router JAKARTA

R-JAKARTA(config)#router ospf 1
R-JAKARTA(config-router)#network 10.10.0.0 255.255.255.252 area 1
R-JAKARTA(config-router)#network 172.17.0.0 255.255.255.252 area 1
R-JAKARTA(config-router)#network 192.168.0.0 255.255.255.252 area 1
R-JAKARTA(config-router)#network 192.168.1.0 255.255.255.252 area 1


Router MAKASSAR

R-MAKASSAR(config)#router ospf 1
R-MAKASSAR(config-router)#network 192.168.1.0 255.255.255.252 area 1
R-MAKASSAR(config-router)#network 172.16.1.0 255.255.255.252 area 1

Perhatikan dalam konfigurasi routing ospf network yang dimasukkan adalah nekwork dengan 1 block yang langsung terkoneksi dengan router yang kita konfigurasi routing ospf didalanya, setelah semua selesai sobat lakukan routingan coba lakukan pengujian dengan “ping”, pastikan semua ip telah terhubung.


Ini capture ping dari router Balikpapan ke router Aceh


R-BALIKPAPAN#ping 10.0.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/9/12 ms


Dan ini dari router Aceh ke router Balikpapan,


R-ACEH#ping 172.16.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/11/15 ms


Selanjutnya mari kita periksa darimana jalur yang ditempuh data dari router Balikpapan menuju router Aceh dengan cara ketik show ip route


R-BALIKPAPAN#show ip route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 2 subnets
O       10.0.0.0 [110/4] via 172.16.1.1, 00:17:37, GigabitEthernet0/0
O       10.10.0.0 [110/3] via 172.16.1.1, 00:23:12, GigabitEthernet0/0
     172.16.0.0/30 is subnetted, 2 subnets
O       172.16.0.0 [110/3] via 172.16.1.1, 00:17:37, GigabitEthernet0/0
C       172.16.1.0 is directly connected, GigabitEthernet0/0
     192.168.0.0/30 is subnetted, 1 subnets
O       192.168.0.0 [110/3] via 172.16.1.1, 00:23:12, GigabitEthernet0/0
     192.168.1.0/30 is subnetted, 1 subnets
O       192.168.1.0 [110/2] via 172.16.1.1, 00:23:12, GigabitEthernet0/0


Tanda dengan huruf "O" menunjukkan OSPF, jadi contoh yang bertanda orange artinya untuk terhubung ke network 10.0.0.0 bisa melalui 172.16.1.1 atau yang sering kita sebut sebagai gateway.

Untuk memeriksa di router lainnya silahkan sobat lakukan sendiri.


Begitulah cara konfigurasi routing ospf pada router cisco, bagi sobat yang masih kurang paham silahkan tinggalkan komentarnya. Bagi sobat yang ingin tau lebih dalam tentang OSPF tunggu postingan saya berikutnya ya..