Skip to content Skip to sidebar Skip to footer

Cara Konfigurasi Port Trunk Pada Switch Cisco

Cara Konfigurasi Port Trunk Pada Switch Cisco - Trunk adalah sebuah mode pada port cisco yang fungsinya untuk melewatkan beberapa vlan secara bersamaan dalam satu port.
Pada Cisco ada 2 (dua) mode port yang paling umum digunakan, pertama mode port access sebagai mode default atau standart, kedua mode port trunk.
Cara konfigurasi port Cisco mode trunk pada router dan switch memiliki perbedaan dikarenakan router berada pada layer 3 OSI sedangkan switch berada pada layer 2 OSI.

Cara konfigurasi port trunk pada switch Cisco


Percobaan ini dilakukan pada aplikasi cisco packet tracer, jadi jika anda belum memiliki aplikasi ini silahkan download terlebih dahulu, anda juga bisa mendownloadnya disini. tapi pada dasarnya tidak ada perbedaan jika dilakukan pada perangkat cisco yang nyata.

Topologi yang digunakan seperti dibawah ini:

Trunk adalah sebuah cara untuk melewatkan lebih dari satu vlan di dalam satu port atau interface


Vlan yang akan di create atau dibuat adalah vlan 10,20,30,40. anda bisa menentukan vlan sendiri sesuai keinginan, tidak harus mengikuti vlan yang saya buat.

Konfigurasi port trunknya sebagai berikut:


  • Buat/tambah vlan :
Switch>enable
Switch#vlan database
Switch(vlan)#vlan 10
VLAN 10 added:
Name: VLAN0010
Switch(vlan)#

Lakukan seperti diatas untuk membuat vlan lainnya. Name vlan secara otomatis akan mengikuti angka vlan yang dibuat, namun nama vlan bisa dibuat sesuai keinginan, caranya:

Switch(vlan)#vlan 50 name VPN
VLAN 50 added:
Name: VPN

Vlan sudah dibuat, selanjutnya konfigurasi port menjadi trunk agar semua vlan yang dibuat tadi bisa lewat ke switch 2960 yang terhubung ke PC.

  • Set port Truk

Switch(vlan)#exit
Switch#conf t
Switch(config)#interface gigabitEthernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 10,20,30,40
Switch(config-if)#no shutdown

Untuk memastikan cek konfigurasi trunk yang sudah dibuat tadi,

Switch(config-if)#exit
Switch#show running-config
Building configuration...
interface GigabitEthernet0/1
switchport trunk allowed vlan 10,20,30,40

Selanjutnya buat vlan dan port trunk dengan cara yang sama pada Switch yang terhubung langsung dengan PC. 

  • Set port access

Kemudian buat port acces yang menuju masing-masing PC, contoh caranya sebagai berikut :

Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10

Kemudian tambahkan ip addres pada salah vlan di Switch utama, dalam kesempatan ini vlan 10,

  • Add ip address

Setelah database vlan dibuat, port trunk dan access dibuat, selanjutnya kita coba tambahkan ip address pada interface vlan yang sudah dibuat sebelumnya.

Caranya :

Switch(config)#interface vlan 10
Switch(config-if)#ip add 10.10.10.1 255.255.255.0

Kemudian konfigurasi ip pada PC yang terhubung ke port acces Switch yang sudah dikonfigurasi sebelumnya. 

  • Tes Ping

Langkah terakhir adalah ujicoba ping ke ip vlan switch utama yang sudah dibuat tadi dari PC, jika sudah benar maka akan replay seperti ini:

C:\>ping 10.10.10.1
Pinging 10.10.10.1 with 32 bytes of data:
Reply from 10.10.10.1: bytes=32 time=1ms TTL=255
Reply from 10.10.10.1: bytes=32 time<1ms TTL=255
Reply from 10.10.10.1: bytes=32 time<1ms TTL=255
Reply from 10.10.10.1: bytes=32 time<1ms TTL=255

Ping statistics for 10.10.10.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms

Demikian cara membuat port jadi trunk pada switch cisco, jika ada yang kurang paham silahkan tinggalkan komentar, semoga membantu.