Skip to content Skip to sidebar Skip to footer

Cara Menghubungkan Router Cisco Ke Internet



Router cisco adalah salah satu perangkat jaringan yang sangat handal dan banyak dijadikan sebagai perangat utama dalam sebuah isp.

Mengapa demikian? karena memang ketangguhannya dalam melayani proses data sudah diakui sejak dahulu, sehingga saat ini cisco juga sudah mengeluarkan aplikasi bernama cisco packet tracer yang banyak digunakan dalam proses pembelajaran cisco.

Pada artikel kali ini serpengetahuan akan berbagi mengenai cara menghubungkan router cisco ke internet.

Tidak semua orang bisa menghubungkan sebuah router cisco ke internet meskipun sudah pernah dan bisa menghubungkan router mikrotik ke internet.

Mengapa demikian? karena cara menghubungkan router cisco ke internet berbeda dengan cara menghubungkan router mikrotik ke internet.

Pada cisco konfigurasi dilakukan full menggunakan metode CLI sedangkan pada Mikrotik ada pilihan untuk menggunakan mode GUI untuk melakukan konfigurasi.

Karena saya tidak memiliki router cisco real alias asli, maka saya menggunakan software simulator GNS3 untuk mempraktekkan step-step yang saya bagikan disini.

Meskipun dilakukan pada aplikasi GNS3, sobat tidak perlu khawatir karena apa yang ada pada GNS3 sama persis dengan yang ada pada cisco asli. 

Itulah salah satu kelebihan dari aplikasi GNS3 ini yang mana system yang digunakan real sesuai dengan firmware cisco yang ada pada perangkat fisik dan juga bisa dihubungkan langsung dengan jaringan real.

Kemudian kelebihan lain dari software GNS3 ini adalah kita bisa download di internet secara gratis berikut dengan jenis perangkat yang kita butuhkan, karena memang kita harus menambahkan perangkat-perangkat yang kita butuhkan secara manual.

Untuk bisa terhubung dengan jaringan real, GNS3 membutuhkan interface loopback yang berfungsi sebagai media penghubung ke jaringan utama (komputer/laptop).

Jika komputer/laptop sobat belum memiliki interface loopback, silahkan sobat buat/install interface loopbacknya terlebih dahulu.

Jika sudah sobat bisa lanjut dengan membuat topologi seperti dibawah ini:

ini adalah artikel mengenai cara menghubungkan router cisco ke internet


Kemudian nayalakan router dengan cara klik kanan pada router kemudian pilih Start, setelah itu klik kanan lagi dan pilih Console untuk mulai melakukan konfigurasi.

Sebelumnya pastikan sobat sudah mengetahui dan bisa melakukan perintah-perintah dasar pada router cisco seperti menambahkan ip address, menambahkan routing dan lain-lain.

Cara Menghubungkan Router Cisco Ke Internet


Jika sudah maka beberapa hal yang harus kita konfigurasi pada router cisco agar bisa terhubung ke internet adalah :

  • Konfigurasi IP Address


Kita akan menambahkan 2 segmen ip address yang berbeda. Yang pertama adalah ip address untuk koneksi ke internet dan yang kedua adalah ip address untuk koneksi ke komputer lokal (lan).

Lakukan konfigurasi ip address pada port/interface router cisco yang menuju ke WAN (internet), disini saya menggunakan interface fa0/0 pada router untuk menuju ke WAN (internet), sobat bisa menyesuaikan dengan selera sobat masing-masing.

Untuk menambahkan ip address pada interface yang menuju ke internet, ada 2 cara atau pilihan untuk melakukannya sesuai dengan mode yang ada yaitu dengan cara dhcp dynamic, juga dengan cara static.

Jika ip address yang di dapat dari internet adalah Static maka bisa dilakukan seperti dibawah ini:

R2(config)#interface fa0/0 
R2(config-if)#no shutdown 
R2(config-if)#ip address 192.168.100.2 255.255.255.0 
R2(config-if)#description to Internet 
R2(config-if)#exit 

Namun jika ip address yang didapat dari WAN (internet) adalah DHCP, maka cara konfigurasi ip address di port/interface yang menuju WAN (internet) adalah:

R2(config)#interface fa0/0 
R2(config-if)#no shutdown 
R2(config-if)#ip address dhcp 
R2(config-if)#description to Internet 
R2(config-if)#exit

Kemudian untuk memastikan interface sudah up, cek dengan perintah "sh ip interface brief"

R2#sh ip int brief 
Interface IP-Address OK? Method Status Protocol 
FastEthernet0/0 192.168.206.136 YES DHCP up up 
FastEthernet1/0 10.1.0.1 YES NVRAM up up 
FastEthernet2/0 192.168.100.2 YES manual up up 
FastEthernet3/0 unassigned YES NVRAM administratively down down 

NVI0 unassigned NO unset up up

Kita bisa melihat ip address pada interface fa0/0 di dapatkan secara DHCP dari WAN (internet). Langkah selanjutnya agar router bisa terhubung denga internet adalah:

  • Konfigurasi Default Route 0.0.0.0/0


Default route 0.0.0.0/0 berfungsi untuk mengarahkan sebuah jaringan kemanapun tujuannya tanpa harus mengetahui ip address berikutnya sampai sebuah router terhubung dengan internet.

R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.206.2

ip address 192.168.206.2 adalah ip address yang bertugas sebagai gerbang utama (gateway) router menuju ke internet, sesuaikan dengan gateway pada jaringan sobat masing-masing.

Kemudian cek kembali apakah default route tadi sudah terdaftar di routing tabel dengan cara ketik perintah "show ip route"

R2#sh ip route 
Gateway of last resort is 192.168.206.2 to network 0.0.0.0 
10.0.0.0/24 is subnetted, 1 subnets 
C 10.1.0.0 is directly connected, FastEthernet1/0 
C 192.168.206.0/24 is directly connected, FastEthernet0/0 
C 192.168.100.0/24 is directly connected, FastEthernet2/0 
S* 0.0.0.0/0 [1/0] via 192.168.206.2 


  • Konfigurasi DNS


DNS berfungsi untuk mengarahkan atau mengenalkan sebuah ip address ke sebuah nama domain dan sebaliknya.

Untuk mengkonfigurasi DNS di router cisco cukup dengan menambahkan perintah ini:

R2(config)#ip domain lookup 
R2(config)#ip name-server 8.8.8.8

Penjelasan :
  • ip domain lookup berfungsi agar dari cisco kita bisa melakukan ping ke sebuah domain, misalnya google.com, detik.com dan lain-lain.
  • ip name-server adalah perintah untuk menambahkan ip dns pada router cisco.

Kemudian langkah terakhir coba lakukan pengujian dengan melakukan ping ke server publik, misal ke google, youtube dan lain-lain.

  • Ping ke google

R2#ping google.com 

Translating "google.com"...domain server (8.8.8.8) [OK] 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.217.194.100, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 148/448/948 ms 
R2#
 
  • Ping ke youtube 

R2#ping youtube.com

Translating "youtube.com"...domain server (8.8.8.8) [OK] 

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.217.194.190, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 148/236/388 ms 
R2#

Dengan demikian, kita sudah berhasil menghubungkan router cisco kita ke internet, langkah selanjutnya adalah membagikan internet ke jaringan LAN, langkah-langkahnya adalah:

  • Konfigurasi NAT Untuk IP Address Lokal (LAN)


Pastikan sobat sudah menambah ip address pada port/interface router cisco yang menuju ke LAN, kemudian ketik perintah berikut ini agar internet di translasikan (NAT) ke segmen ip LAN yang sudah sobat buat.

R2(config)#access-list 1 permit 10.1.0.0 0.0.255.255 
R2(config)#ip nat inside source list 1 interface FastEthernet0/0 overload
 

Penjelasan :

  • access-list 1 permit 10.1.0.0 0.0.255.25 adalah ip address lokal (lan)

Kemudian masuk ke interface yang menuju WAN (internet), kemudian ketik perintah "ip nat outside

R2(config)#interface fa0/0 
R2(config-if)#ip nat outside

Terakhir masuk ke port/interface yang menuju ke jaringan lokal (LAN) dan ketik perintah "ip nat inside"
 
R2(config)#interface fa1/0 
R2(config-if)#ip nat inside
 

Terakhir lakukan ping ke google dengan menambahkan source address ip lokal:

R2#ping google.com source 10.1.0.1

Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.217.194.139, timeout is 2 seconds: 
Packet sent with a source address of 10.1.0.1 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 148/372/1064 ms 
R2#

Dengan demikian router sudah terhubung ke internet, jaringan LAN juga sudah terhubung ke internet. Demikian cara menghubungkan router ke internet, semoga bermanfaat dan selamat mencoba.

Salam..
serpengetahuan